rinetd-0.62-r2.ebuild 689 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="6"
  4. inherit toolchain-funcs
  5. DESCRIPTION="redirects TCP connections from one IP address and port to another"
  6. HOMEPAGE="http://www.boutell.com/rinetd/"
  7. SRC_URI="http://www.boutell.com/rinetd/http/rinetd.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE=""
  12. S=${WORKDIR}/${PN}
  13. src_prepare() {
  14. default
  15. sed -i -e "s:gcc:$(tc-getCC) \$(CFLAGS) \$(LDFLAGS):" Makefile
  16. }
  17. src_compile() {
  18. emake CFLAGS="${CFLAGS} -DLINUX" LDFLAGS="${LDFLAGS}"
  19. }
  20. src_install() {
  21. dosbin rinetd
  22. newinitd "${FILESDIR}"/rinetd.rc rinetd
  23. doman rinetd.8
  24. dodoc CHANGES README index.html
  25. }