shigofumi-0.3.ebuild 994 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. EGIT_REPO_URI='git://repo.or.cz/shigofumi.git'
  5. WANT_AUTOMAKE="1.11"
  6. inherit base
  7. [[ ${PV} = 9999* ]] && inherit git-2 autotools
  8. DESCRIPTION="Command line client for ISDS"
  9. HOMEPAGE="http://xpisar.wz.cz/shigofumi/"
  10. if [[ ${PV} = 9999* ]]; then
  11. SRC_URI=""
  12. KEYWORDS=""
  13. else
  14. SRC_URI="http://xpisar.wz.cz/${PN}/dist/${P}.tar.bz2"
  15. KEYWORDS="~amd64 ~mips ~x86"
  16. fi
  17. LICENSE="GPL-3"
  18. SLOT="0"
  19. IUSE="debug doc nls xattr"
  20. RDEPEND="dev-libs/confuse
  21. dev-libs/libxml2
  22. sys-libs/readline
  23. >=net-libs/libisds-0.7"
  24. DEPEND="${RDEPEND}
  25. virtual/pkgconfig
  26. doc? (
  27. app-text/docbook-xsl-stylesheets
  28. dev-libs/libxslt
  29. )
  30. nls? ( sys-devel/gettext )"
  31. DOCS=( NEWS README AUTHORS ChangeLog )
  32. src_prepare() {
  33. [[ ${PV} = 9999* ]] && eautoreconf
  34. }
  35. src_configure() {
  36. econf \
  37. --disable-fatalwarnings \
  38. $(use_enable debug) \
  39. $(use_enable doc) \
  40. $(use_enable nls) \
  41. $(use_enable xattr)
  42. }