sipsak-0.9.6_p1-r1.ebuild 730 B

123456789101112131415161718192021222324252627282930313233343536
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils
  5. DESCRIPTION="small command line tool for testing SIP applications and devices"
  6. HOMEPAGE="https://sourceforge.net/projects/sipsak.berlios/"
  7. SRC_URI="mirror://sourceforge/sipsak.berlios/${P/_p/-}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
  11. IUSE="gnutls"
  12. RDEPEND="gnutls? ( net-libs/gnutls )
  13. net-dns/c-ares"
  14. DEPEND="${RDEPEND}"
  15. S=${WORKDIR}/${P/_p1}
  16. src_prepare() {
  17. epatch "${FILESDIR}/${PV}-callback.patch"
  18. }
  19. src_configure() {
  20. econf \
  21. $(use_enable gnutls)
  22. }
  23. src_install() {
  24. emake DESTDIR="${D}" install || die
  25. dodoc AUTHORS ChangeLog NEWS README TODO
  26. }