sitecopy-0.16.6-r1.ebuild 3.3 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools eutils
  5. DESCRIPTION="Maintain remote web sites with ease"
  6. SRC_URI="http://www.manyfish.co.uk/sitecopy/${P}.tar.gz
  7. https://dev.gentoo.org/~idella4/sitecopy-0.16.6-04-manpages-addition-fixes.patch"
  8. HOMEPAGE=" http://www.manyfish.co.uk/sitecopy/"
  9. # Removed all Debian related stuff. If you want more patches, they can be ported from
  10. # http://ftp.debian.org/debian/pool/main/s/sitecopy/
  11. # The sitecopy_0.16.6-5.debian.tar.gz contains their build scripts and patches.
  12. # This SiteCopy now builds using the original sources.
  13. KEYWORDS="amd64 x86"
  14. LICENSE="GPL-2"
  15. SLOT="0"
  16. IUSE="expat nls rsh ssl webdav xml zlib"
  17. # TODO: Depends copied over from old ebuild file, ensure they're still correct!
  18. DEPEND="rsh? ( net-misc/netkit-rsh )
  19. >=net-libs/neon-0.24.6[zlib?,ssl?,expat?]
  20. <=net-libs/neon-0.30.9999[zlib?,ssl?,expat?]
  21. xml? ( >=net-libs/neon-0.24.6[-expat] )"
  22. RDEPEND="${DEPEND}"
  23. src_prepare() {
  24. # NOTE: Insert patches here.
  25. # SiteCopy patches are being currently pulled & ported from
  26. # http://ftp.debian.org/debian/pool/main/s/sitecopy/
  27. # Consider SiteCopy to be more or less being actively maintained by
  28. # Debian maintainers, but GPL patches ported into Gentoo.
  29. # NOTE: epatch is provided by 'inherit eutils'
  30. # Patch File Naming Format
  31. # files/package_name - package_version - patch_order - patch_description
  32. epatch "${FILESDIR}/sitecopy-0.16.6-01-remote-dynamic-rc.patch" \
  33. "${FILESDIR}/sitecopy-0.16.6-02-french-po-fix.patch" \
  34. "${FILESDIR}/sitecopy-0.16.6-03-wrong-memory-397155.patch" \
  35. "${FILESDIR}/sitecopy-0.16.6-06-sftpdriver.c-fix-for-new-openssh.patch" \
  36. "${FILESDIR}/sitecopy-0.16.6-10-bts410703-preserve-storage-files-sigint.patch" \
  37. "${FILESDIR}/sitecopy-0.16.6-20-bts549721-add-compatibility-for-neon-0.29.0.patch" \
  38. "${FILESDIR}/sitecopy-0.16.6-30-bts320586-manpage-document-sftp.patch" \
  39. "${DISTDIR}/sitecopy-0.16.6-04-manpages-addition-fixes.patch"
  40. # Source package uses incorrect '/usr/doc' for the doc folder. So use
  41. # sed to correct this error.
  42. sed -i -e "s:docdir \= .*:docdir \= \$\(prefix\)\/share/doc\/${PF}:" \
  43. Makefile.in || die "Documentation directory patching failed"
  44. # NOTE: eautoconf/eautomake is provided by 'inherit autotools'
  45. # Need to recreate the source package provided configure script,
  46. # because the package provided configure script only supports
  47. # <neon-0.30.0 support. A patch above patches the configure.in
  48. # providing neon-0.30.0 support, and we then recreate the configure
  49. # script based upon configure.in using autotools.
  50. # First move configure.in to configure.ac, required by newer >autoconf-2.13
  51. # per Bug #426262 automake-1.14 compatibility
  52. # Should check first, autoconf-2.13 is still in the tree requiring configure.in!
  53. # mv configure.in configure.ac || die
  54. eautoconf
  55. eautomake
  56. }
  57. src_configure() {
  58. # TODO: USE functions copied over from old ebuild file, ensure they're still correct!
  59. econf $(use_with ssl ssl openssl) \
  60. $(use_enable webdav) \
  61. $(use_enable nls) \
  62. $(use_enable rsh) \
  63. $(use_with expat) \
  64. $(use_with xml libxml2 ) \
  65. --with-neon \
  66. || die "econf failed"
  67. }
  68. src_compile() {
  69. emake || die "emake failed"
  70. }
  71. src_install() {
  72. emake DESTDIR="${D}" install || die "emake install failed"
  73. }