socket-1.5.ebuild 606 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit base toolchain-funcs
  5. DESCRIPTION="A shell-level interface to TCP sockets"
  6. HOMEPAGE="http://www.jnickelsen.de/socket/"
  7. SRC_URI="http://www.jnickelsen.de/${PN}/${P}.tar.gz"
  8. LICENSE="BSD-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86 ~amd64-linux"
  11. IUSE="examples"
  12. PATCHES=( "${FILESDIR}/${P}-makefile.patch" )
  13. src_compile() {
  14. emake CC="$(tc-getCC)"
  15. }
  16. src_install() {
  17. dobin socket
  18. doman socket.1
  19. dodoc BLURB CHANGES README
  20. if use examples; then
  21. docinto examples
  22. dodoc scripts/*
  23. fi
  24. }