ssh-askpass-fullscreen-1.0-r1.ebuild 999 B

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit autotools eutils
  5. DESCRIPTION="A small SSH Askpass replacement written with GTK2"
  6. HOMEPAGE="https://github.com/atj/ssh-askpass-fullscreen"
  7. SRC_URI="mirror://github/atj/${PN}/${P}.tar.bz2"
  8. LICENSE="GPL-2+"
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 ia64 ppc sparc x86 ~x86-fbsd"
  11. IUSE=""
  12. RDEPEND=">=x11-libs/gtk+-2.10.0:2
  13. x11-libs/libX11"
  14. DEPEND="${RDEPEND}
  15. virtual/pkgconfig"
  16. src_prepare() {
  17. # https://github.com/atj/ssh-askpass-fullscreen/pull/1
  18. epatch "${FILESDIR}/${P}-libX11.patch"
  19. # automake-1.13 fix, bug #468764
  20. sed -i -e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' configure.ac || die
  21. eautoreconf
  22. }
  23. src_install() {
  24. default
  25. # Automatically display the passphrase dialog - see bug #437764
  26. echo "SSH_ASKPASS='${EPREFIX}/usr/bin/ssh-askpass-fullscreen'" >> "${T}/99ssh_askpass" \
  27. || die "envd file creation failed"
  28. doenvd "${T}"/99ssh_askpass || die "doenvd failed"
  29. }