tn5250-0.17.4-r1.ebuild 1.2 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit eutils
  5. DESCRIPTION="Telnet client for the IBM AS/400 that emulates 5250 terminals and printers"
  6. HOMEPAGE="http://tn5250.sourceforge.net/"
  7. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
  8. LICENSE="LGPL-2.1"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc ~sparc x86"
  11. IUSE="X libressl ssl"
  12. RDEPEND="
  13. sys-libs/ncurses:=
  14. ssl? (
  15. !libressl? ( dev-libs/openssl:0= )
  16. libressl? ( dev-libs/libressl:0= )
  17. )
  18. "
  19. DEPEND="${RDEPEND}
  20. X? ( x11-libs/libXt )
  21. "
  22. src_prepare() {
  23. default
  24. # Next, the Makefile for the terminfo settings tries to remove
  25. # some files it doesn't have access to. We can just remove those
  26. # lines.
  27. cd "${S}/linux"
  28. sed -i \
  29. -e "/rm -f \/usr\/.*\/terminfo.*5250/d" Makefile.in \
  30. || die "sed Makefile.in failed"
  31. cd "${S}"
  32. }
  33. src_configure() {
  34. econf \
  35. --disable-static \
  36. --without-python \
  37. $(use_with X x) \
  38. $(use_with ssl)
  39. }
  40. src_install() {
  41. # The TERMINFO variable needs to be defined for the install
  42. # to work, because the install calls "tic." man tic for
  43. # details.
  44. dodir /usr/share/terminfo
  45. emake DESTDIR="${D}" \
  46. TERMINFO="${D}/usr/share/terminfo" install
  47. einstalldocs
  48. prune_libtool_files
  49. }