urlview-0.9.ebuild 1.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools eutils
  5. DESCRIPTION="extracts urls from text and will send them to another app"
  6. HOMEPAGE="http://www.mutt.org"
  7. SRC_URI="ftp://gd.tuwien.ac.at/infosys/mail/mutt/contrib/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 arm ia64 ppc ppc64 s390 sh sparc x86"
  11. RDEPEND="
  12. >=sys-libs/ncurses-5.2
  13. "
  14. DEPEND="
  15. ${RDEPEND}
  16. virtual/pkgconfig
  17. "
  18. src_prepare() {
  19. epatch \
  20. "${FILESDIR}"/no-trailing-newline.patch \
  21. "${FILESDIR}"/include-fix.patch \
  22. "${FILESDIR}"/${P}-DESTDIR.patch \
  23. "${FILESDIR}"/${P}-tinfo.patch
  24. eautoreconf
  25. }
  26. src_install() {
  27. default
  28. dodoc README INSTALL ChangeLog AUTHORS sample.urlview
  29. dobin url_handler.sh
  30. }
  31. pkg_postinst() {
  32. echo
  33. einfo "There is a sample.urlview in /usr/share/doc/${P}"
  34. einfo "You can also customize /usr/bin/url_handler.sh"
  35. echo
  36. einfo "If using urlview from mutt, you may need to "set pipe_decode" in"
  37. einfo "your ~/.muttrc to prevent garbled URLs."
  38. echo
  39. }