vconfig-1.9.ebuild 1.1 KB

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 1999-2009 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit eutils flag-o-matic toolchain-funcs
  4. MY_PN="vlan"
  5. S=${WORKDIR}/${MY_PN}
  6. DESCRIPTION="802.1Q vlan control utility"
  7. HOMEPAGE="http://www.candelatech.com/~greear/vlan.html"
  8. SRC_URI="http://www.candelatech.com/~greear/vlan/${MY_PN}.${PV}.tar.gz"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="~alpha amd64 ~arm hppa ~ppc ~ppc64 sparc x86"
  12. IUSE="static"
  13. src_compile() {
  14. use static && appened-ldflags -static
  15. emake purge
  16. emake CC="$(tc-getCC)" CCFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" STRIP="true" vconfig || die
  17. }
  18. src_install() {
  19. into /
  20. dosbin vconfig || die "dosbin error"
  21. sed -e "s:/usr/local/bin/vconfig:/sbin/vconfig:g" -i vlan_test.pl
  22. sed -e "s:/usr/local/bin/vconfig:/sbin/vconfig:g" -i vlan_test2.pl
  23. doman vconfig.8 || die "doman error"
  24. dohtml howto.html vlan.html || die "dohtml error"
  25. dodoc CHANGELOG README vlan_test*.pl || die "dodoc error"
  26. }
  27. pkg_postinst() {
  28. ewarn "MTU problems exist for many ethernet drivers."
  29. ewarn "Reduce the MTU on the interface to 1496 to work around them."
  30. }