123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100 |
- # Copyright 1999-2017 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI="5"
- PYTHON_COMPAT=( python3_4 )
- inherit flag-o-matic python-any-r1 toolchain-funcs eutils
- DESCRIPTION="Network utility to retrieve files from the WWW"
- HOMEPAGE="https://www.gnu.org/software/wget/"
- SRC_URI="mirror://gnu/wget/${P}.tar.xz"
- LICENSE="GPL-3"
- SLOT="0"
- KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
- IUSE="debug gnutls idn ipv6 libressl nls ntlm pcre +ssl static test uuid zlib"
- REQUIRED_USE=" ntlm? ( !gnutls ssl ) gnutls? ( ssl )"
- LIB_DEPEND="idn? ( net-dns/libidn[static-libs(+)] )
- pcre? ( dev-libs/libpcre[static-libs(+)] )
- ssl? (
- gnutls? ( net-libs/gnutls:0=[static-libs(+)] )
- !gnutls? (
- !libressl? ( dev-libs/openssl:0=[static-libs(+)] )
- libressl? ( dev-libs/libressl[static-libs(+)] )
- )
- )
- uuid? ( sys-apps/util-linux[static-libs(+)] )
- zlib? ( sys-libs/zlib[static-libs(+)] )"
- RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
- DEPEND="${RDEPEND}
- app-arch/xz-utils
- virtual/pkgconfig
- static? ( ${LIB_DEPEND} )
- test? (
- ${PYTHON_DEPS}
- dev-lang/perl
- dev-perl/HTTP-Daemon
- dev-perl/HTTP-Message
- dev-perl/IO-Socket-SSL
- )
- nls? ( sys-devel/gettext )"
- DOCS=( AUTHORS MAILING-LIST NEWS README doc/sample.wgetrc )
- pkg_setup() {
- use test && python-any-r1_pkg_setup
- }
- src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.17.1-gnulib-cygwin-sys_select.patch
- # revert some hack that breaks linking, bug #585924
- if [[ ${CHOST} == *-darwin* ]] || [[ ${CHOST} == *-solaris* ]] || [[ ${CHOST} == *-uclibc* ]]; then
- sed -i \
- -e 's/^ LIBICONV=$/:/' \
- configure || die
- fi
- }
- src_configure() {
- # fix compilation on Solaris, we need filio.h for FIONBIO as used in
- # the included gnutls -- force ioctl.h to include this header
- [[ ${CHOST} == *-solaris* ]] && append-cppflags -DBSD_COMP=1
- if use static ; then
- append-ldflags -static
- tc-export PKG_CONFIG
- PKG_CONFIG+=" --static"
- fi
- econf \
- --disable-assert \
- --disable-rpath \
- $(use_with ssl ssl $(usex gnutls gnutls openssl)) \
- $(use_enable ssl opie) \
- $(use_enable ssl digest) \
- $(use_enable idn iri) \
- $(use_enable ipv6) \
- $(use_enable nls) \
- $(use_enable ntlm) \
- $(use_enable pcre) \
- $(use_enable debug) \
- $(use_with uuid libuuid) \
- $(use_with zlib)
- }
- src_test() {
- emake check
- }
- src_install() {
- default
- sed -i \
- -e "s:/usr/local/etc:${EPREFIX}/etc:g" \
- "${ED}"/etc/wgetrc \
- "${ED}"/usr/share/man/man1/wget.1 \
- "${ED}"/usr/share/info/wget.info
- }
|