whatportis-0.6.ebuild 851 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PYTHON_COMPAT=( python{2_7,3_{4,5}} )
  5. inherit distutils-r1 eutils
  6. DESCRIPTION="A command to search port names and numbers"
  7. HOMEPAGE="https://github.com/ncrocfer/whatportis http://pypi.python.org/pypi/whatportis"
  8. SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
  9. LICENSE="MIT"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
  12. IUSE="test"
  13. RDEPEND="
  14. >=dev-python/click-6.2[${PYTHON_USEDEP}]
  15. >=dev-python/prettytable-0.7.2[${PYTHON_USEDEP}]
  16. >=dev-python/tinydb-3.1.2[${PYTHON_USEDEP}]
  17. >=dev-python/simplejson-3.8.1[${PYTHON_USEDEP}]
  18. "
  19. DEPEND="${RDEPEND}
  20. dev-python/setuptools[${PYTHON_USEDEP}]"
  21. python_test() {
  22. "${EPYTHON}" test_${PN}.py || die
  23. }
  24. pkg_postinst() {
  25. optfeature "Run ${PN} as a Server" dev-python/flask
  26. }