zssh-1.5c-r1.ebuild 891 B

12345678910111213141516171819202122232425262728293031323334353637383940414243444546
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils toolchain-funcs
  5. DESCRIPTION="An ssh wrapper enabling zmodem up/download in ssh"
  6. HOMEPAGE="http://zssh.sourceforge.net/"
  7. SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ~ppc sparc x86"
  11. IUSE="nls readline"
  12. DEPEND="readline? (
  13. sys-libs/ncurses
  14. sys-libs/readline:0
  15. )"
  16. RDEPEND="${DEPEND}
  17. net-misc/openssh
  18. net-dialup/lrzsz"
  19. src_prepare() {
  20. epatch "${FILESDIR}/${PN}-1.5a-gentoo-include.diff"
  21. # Fix linking with sys-libs/ncurses[tinfo], bug #527036
  22. sed -i -e 's/-ltermcap/-ltinfo/g' configure || die
  23. epatch_user
  24. }
  25. src_configure() {
  26. tc-export AR CC RANLIB
  27. econf \
  28. $(use_enable nls) \
  29. $(use_enable readline)
  30. }
  31. src_install() {
  32. dobin ${PN} ztelnet
  33. doman ${PN}.1 ztelnet.1
  34. dodoc CHANGES FAQ README TODO
  35. }