canto-curses-0.9.3.ebuild 630 B

1234567891011121314151617181920212223242526
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. PYTHON_COMPAT=( python3_4 )
  5. PYTHON_REQ_USE="ncurses(+),threads(+)"
  6. inherit distutils-r1 multilib
  7. DESCRIPTION="The ncurses client for canto-daemon"
  8. HOMEPAGE="http://codezen.org/canto-ng/"
  9. SRC_URI="http://codezen.org/static/${P}.tar.gz"
  10. LICENSE="GPL-2"
  11. SLOT="0"
  12. KEYWORDS="~amd64 ~x86"
  13. RDEPEND=">=net-news/canto-daemon-0.9.1[${PYTHON_USEDEP}]"
  14. python_prepare_all() {
  15. # Respect libdir during plugins installation
  16. sed -i -e "s:lib/canto:$(get_libdir)/canto:" setup.py || die
  17. distutils-r1_python_prepare_all
  18. }