slrnconf-0.8.4.ebuild 719 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. DESCRIPTION="slrnconf is a graphical configuration utility for the newsreader slrn"
  4. HOMEPAGE="http://home.arcor.de/kaffeetisch/slrnconf.html"
  5. SRC_URI="http://home.arcor.de/kaffeetisch/downloads/${P}.tar.bz2"
  6. LICENSE="GPL-2"
  7. SLOT="0"
  8. KEYWORDS="~amd64 ~ppc x86"
  9. IUSE=""
  10. RDEPEND="dev-lang/perl
  11. dev-perl/Gtk2
  12. dev-perl/Parse-RecDescent
  13. net-nntp/slrn"
  14. DEPEND="${RDEPEND}
  15. >=sys-apps/sed-4"
  16. src_unpack() {
  17. unpack ${A}
  18. sed -i -e 's/^install: all$/install:/' ${S}/Makefile
  19. }
  20. src_compile() {
  21. make PREFIX=/usr || die "make failed"
  22. }
  23. src_install() {
  24. make PREFIX=${D}/usr install || die "make install failed"
  25. }