cups-pdf-3.0.1.ebuild 891 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit toolchain-funcs
  5. DESCRIPTION="Provides a virtual printer for CUPS to produce PDF files"
  6. HOMEPAGE="http://www.cups-pdf.de/"
  7. SRC_URI="http://www.cups-pdf.de/src/${PN}_${PV/_}.tar.gz"
  8. LICENSE="GPL-2+"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~arm ~ppc ~x86"
  11. IUSE="+ppds"
  12. RDEPEND="
  13. net-print/cups
  14. app-text/ghostscript-gpl
  15. "
  16. DEPEND="${RDEPEND}"
  17. S=${WORKDIR}/${PN}-${PV/_}
  18. src_compile() {
  19. pushd src >/dev/null
  20. $(tc-getCC) ${LDFLAGS} ${CFLAGS} ${PN}.c -o ${PN} -lcups || die
  21. popd >/dev/null
  22. }
  23. src_install() {
  24. exeinto /usr/libexec/cups/backend
  25. exeopts -m0700
  26. doexe src/cups-pdf
  27. insinto /etc/cups
  28. doins extra/cups-pdf.conf
  29. insinto /usr/share/cups/model
  30. if use ppds; then
  31. doins extra/CUPS-PDF_opt.ppd
  32. else
  33. doins extra/CUPS-PDF_noopt.ppd
  34. fi
  35. dodoc ChangeLog README
  36. }