fax4cups-1.29-r1.ebuild 944 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. DESCRIPTION="Fax backend for CUPS"
  5. HOMEPAGE="http://vigna.dsi.unimi.it/fax4CUPS/"
  6. SRC_URI="http://vigna.dsi.unimi.it/fax4CUPS/fax4CUPS-${PV}.tar.gz"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="amd64 ~ppc x86"
  10. IUSE="+hylafax mgetty-fax efax"
  11. REQUIRED_USE="|| ( hylafax mgetty-fax efax )"
  12. DEPEND="net-print/cups"
  13. RDEPEND="${DEPEND}
  14. || (
  15. hylafax? ( net-misc/hylafaxplus )
  16. efax? ( net-misc/efax )
  17. mgetty-fax? ( net-dialup/mgetty )
  18. )
  19. app-admin/sudo
  20. "
  21. S=${WORKDIR}/fax4CUPS-${PV}
  22. src_install() {
  23. doman fax4CUPS.1
  24. exeinto $(cups-config --serverbin)/backend
  25. insinto /usr/share/cups/model
  26. for i in hylafax efax mgetty-fax; do
  27. if use $i
  28. then
  29. # Backend
  30. doexe $i
  31. # PPD
  32. doins $i.ppd
  33. fi
  34. done
  35. }
  36. pkg_postinst() {
  37. elog "Please execute '/etc/init.d/cups restart'"
  38. elog "to get the *.ppd files working properly"
  39. }