libinklevel-0.9.2.ebuild 842 B

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools eutils multilib
  5. MY_P="${P/_/}"
  6. DESCRIPTION="A library to get the ink level of your printer"
  7. HOMEPAGE="http://libinklevel.sourceforge.net/"
  8. SRC_URI="mirror://sourceforge/libinklevel/${MY_P}.tar.gz"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~ppc ~x86"
  11. LICENSE="GPL-2"
  12. IUSE="debug static-libs"
  13. DEPEND=">=sys-libs/libieee1284-0.2.11
  14. virtual/libusb:1"
  15. RDEPEND="${DEPEND}"
  16. S="${WORKDIR}/${MY_P}"
  17. src_prepare() {
  18. sed -i -e "/^dist_doc_DATA/d" Makefile.am \
  19. || die "Failed to disable installation of docs"
  20. eautoreconf
  21. }
  22. src_configure() {
  23. econf $(use_enable debug)
  24. }
  25. src_install () {
  26. emake DESTDIR="${D}" install
  27. dodoc AUTHORS ChangeLog NEWS README
  28. use static-libs || rm "${D}"/usr/$(get_libdir)/libinklevel.{a,la}
  29. }