pnm2ppa-1.13-r1.ebuild 1.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit base
  5. DESCRIPTION="Print driver for Hp Deskjet 710, 712, 720, 722, 820, 1000 series"
  6. HOMEPAGE="http://pnm2ppa.sourceforge.net"
  7. SRC_URI="mirror://sourceforge/pnm2ppa/${P}.tar.gz"
  8. KEYWORDS="~amd64 ~x86"
  9. SLOT="0"
  10. LICENSE="GPL-2"
  11. IUSE="syslog"
  12. # en on first place so others can override it
  13. LANGS="en cs es fr it nl"
  14. for lng in ${LANGS}; do
  15. IUSE+=" linguas_${lng}"
  16. done
  17. RDEPEND="
  18. app-text/ghostscript-gpl
  19. net-print/cups
  20. || ( >=net-print/cups-filters-1.0.43-r1[foomatic] net-print/foomatic-filters )
  21. sys-libs/glibc
  22. syslog? ( virtual/logger )
  23. "
  24. DEPEND="${RDEPEND}"
  25. src_configure() {
  26. local lng i withval
  27. for lng in ${LANGS}; do
  28. if use linguas_${lng}; then
  29. if [[ -n ${i} ]] ; then
  30. ewarn "This package supports only one translation at a time."
  31. ewarn "Overriding previous value: \"${withval}\" with \"${lng}\""
  32. fi
  33. withval="${lng}"
  34. i=true
  35. fi
  36. done
  37. econf \
  38. --with-language="${lng}" \
  39. --enable-vlink \
  40. $(use_enable syslog)
  41. }
  42. src_install() {
  43. default
  44. dobin utils/Linux/detect_ppa utils/Linux/test_ppa
  45. insinto /usr/share/pnm2ppa
  46. doins -r lpd pdq
  47. exeinto /usr/share/pnm2ppa/lpd
  48. doexe lpd/lpdsetup
  49. exeinto /usr/share/pnm2ppa/sample_scripts
  50. doexe sample_scripts/*
  51. exeinto /etc/pdq/drivers/ghostscript
  52. doexe pdq/gs-pnm2ppa
  53. exeinto /etc/pdq/interfaces
  54. doexe pdq/dummy
  55. # install docs
  56. cd docs/en
  57. dodoc CALIBRATION*txt COLOR*txt PPA*txt RELEASE* CREDITS README sgml/*.sgml
  58. cd "${S}"
  59. dohtml -r .
  60. }