xerox-drivers-0_p20080123.ebuild 822 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="2"
  4. MY_PN="LinuxCupsPrinterPkg"
  5. DESCRIPTION="PPD files of XEROX printers (CopyCentre, DocuPrint, Phaser, WorkCentre) for CUPS printing system"
  6. HOMEPAGE="http://www.support.xerox.com/go/getfile.asp?objid=61334&prodID=6180"
  7. SRC_URI="http://download.support.xerox.com/pub/drivers/DocuColor_2006/drivers/unix/en/${MY_PN}.tar.gz"
  8. LICENSE="Xerox"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE=""
  12. RESTRICT="bindist fetch"
  13. DEPEND=""
  14. RDEPEND="net-print/cups"
  15. S="${WORKDIR}/${MY_PN}"
  16. # Suppressing warnings from the incorrect upstream tarball
  17. src_unpack() {
  18. unpack ${A} 2> /dev/null
  19. }
  20. src_install() {
  21. dodoc Readme.txt || die "missing Readme.txt"
  22. insinto /usr/share/cups/model
  23. doins *.ppd || die "missing ppd files"
  24. }