miredo-1.2.6.ebuild 1.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit autotools eutils linux-info user
  5. DESCRIPTION="Miredo is an open-source Teredo IPv6 tunneling software"
  6. HOMEPAGE="http://www.remlab.net/miredo/"
  7. SRC_URI="http://www.remlab.net/files/${PN}/${P}.tar.xz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE="+caps"
  12. RDEPEND="sys-apps/iproute2
  13. dev-libs/judy
  14. caps? ( sys-libs/libcap )"
  15. DEPEND="${RDEPEND}
  16. app-arch/xz-utils"
  17. CONFIG_CHECK="~IPV6" #318777
  18. #tries to connect to external networks (#339180)
  19. RESTRICT="test"
  20. DOCS=( AUTHORS ChangeLog NEWS README TODO THANKS )
  21. src_prepare() {
  22. epatch "${FILESDIR}"/${PN}-1.2.5-configure-libcap.diff
  23. epatch "${FILESDIR}"/${PN}-1.2.5-ip-path.patch
  24. eautoreconf
  25. }
  26. src_configure() {
  27. econf \
  28. --disable-static \
  29. --enable-miredo-user \
  30. --localstatedir=/var \
  31. $(use_with caps libcap)
  32. }
  33. src_install() {
  34. default
  35. prune_libtool_files
  36. newinitd "${FILESDIR}"/miredo.rc.2 miredo
  37. newconfd "${FILESDIR}"/miredo.conf.2 miredo
  38. newinitd "${FILESDIR}"/miredo.rc.2 miredo-server
  39. newconfd "${FILESDIR}"/miredo.conf.2 miredo-server
  40. insinto /etc/miredo
  41. doins misc/miredo-server.conf
  42. }
  43. pkg_preinst() {
  44. enewgroup miredo
  45. enewuser miredo -1 -1 /var/empty miredo
  46. }