tinc-1.0.29.ebuild 1.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="6"
  4. inherit systemd
  5. DESCRIPTION="tinc is an easy to configure VPN implementation"
  6. HOMEPAGE="http://www.tinc-vpn.org/"
  7. SRC_URI="http://www.tinc-vpn.org/packages/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
  11. IUSE="libressl +lzo uml vde +zlib"
  12. DEPEND="
  13. !libressl? ( dev-libs/openssl:0= )
  14. libressl? ( dev-libs/libressl:0= )
  15. lzo? ( dev-libs/lzo:2 )
  16. zlib? ( sys-libs/zlib )"
  17. RDEPEND="${DEPEND}
  18. vde? ( net-misc/vde )"
  19. src_configure() {
  20. econf \
  21. --enable-jumbograms \
  22. --disable-tunemu \
  23. $(use_enable lzo) \
  24. $(use_enable uml) \
  25. $(use_enable vde) \
  26. $(use_enable zlib)
  27. }
  28. src_install() {
  29. emake DESTDIR="${D}" install
  30. dodir /etc/tinc
  31. dodoc AUTHORS NEWS README THANKS
  32. doconfd "${FILESDIR}"/tinc.networks
  33. newconfd "${FILESDIR}"/tincd.conf tincd
  34. newinitd "${FILESDIR}"/tincd-r1 tincd
  35. systemd_newunit "${FILESDIR}"/tincd_at.service "tincd@.service"
  36. }
  37. pkg_postinst() {
  38. elog "This package requires the tun/tap kernel device."
  39. elog "Look at http://www.tinc-vpn.org/ for how to configure tinc"
  40. }