bladerf-2015.02.ebuild 1.3 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit cmake-utils udev
  5. DESCRIPTION="Libraries for supporing the BladeRF hardware from Nuand"
  6. HOMEPAGE="http://nuand.com/"
  7. #lib is LGPL and cli tools are GPL
  8. LICENSE="GPL-2+ LGPL-2.1+"
  9. SLOT="0/${PV}"
  10. #maintainer notes:
  11. #doc use flag, looks like it can't be disabled right now and will
  12. # always build if pandoc and help2man are installed
  13. # also ignores when deps are missing and just disables docs
  14. IUSE="doc +tecla"
  15. MY_PN="bladeRF"
  16. if [[ ${PV} == "9999" ]] ; then
  17. inherit git-r3
  18. EGIT_REPO_URI="https://github.com/Nuand/${MY_PN}.git"
  19. KEYWORDS=""
  20. else
  21. MY_PV=${PV/\_/-}
  22. S="${WORKDIR}/${MY_PN}-${MY_PV}"
  23. SRC_URI="https://github.com/Nuand/${MY_PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
  24. KEYWORDS="~amd64 ~arm ~x86"
  25. fi
  26. CDEPEND=">=dev-libs/libusb-1.0.16
  27. tecla? ( dev-libs/libtecla )"
  28. DEPEND="${CDEPEND}
  29. virtual/pkgconfig"
  30. RDEPEND="${CDEPEND}"
  31. PDEPEND=">=net-wireless/bladerf-firmware-1.8.0
  32. >=net-wireless/bladerf-fpga-0.1.2"
  33. src_configure() {
  34. mycmakeargs=(
  35. -DVERSION_INFO_OVERRIDE:STRING="${PV}"
  36. $(cmake-utils_use_enable doc BUILD_DOCUMENTATION)
  37. $(cmake-utils_use_enable tecla LIBTECLA)
  38. -DTREAT_WARNINGS_AS_ERRORS=OFF
  39. -DUDEV_RULES_PATH="$(get_udevdir)"/rules.d
  40. )
  41. cmake-utils_src_configure
  42. }