cpyrit-cuda-0.5.0.ebuild 859 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PYTHON_COMPAT=( python2_7 )
  5. DISTUTILS_SINGLE_IMPL=1
  6. inherit toolchain-funcs distutils-r1
  7. DESCRIPTION="A sub-package that adds CUDA-capability to Pyrit"
  8. HOMEPAGE="https://github.com/JPaulMora/Pyrit"
  9. SRC_URI="https://github.com/JPaulMora/Pyrit/archive/v${PV}.tar.gz -> pyrit-${PV}.tar.gz"
  10. LICENSE="GPL-3+ GPL-3+-with-cuda-exception GPL-3+-with-cuda-openssl-exception"
  11. SLOT="0"
  12. KEYWORDS="~amd64 ~x86"
  13. DEPEND="
  14. dev-libs/openssl:=
  15. net-libs/libpcap
  16. dev-util/nvidia-cuda-toolkit"
  17. RDEPEND="${DEPEND}"
  18. PDEPEND="~net-wireless/pyrit-${PV}"
  19. S="${WORKDIR}/Pyrit-${PV}/modules/cpyrit_cuda"
  20. pkg_pretend() {
  21. if tc-is-gcc && [[ $(gcc-version) > 4.8 ]]; then
  22. die "gcc 4.9 and up are not supported"
  23. fi
  24. }
  25. pkg_setup() {
  26. python-single-r1_pkg_setup
  27. }