iw-4.0.ebuild 753 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit toolchain-funcs
  5. DESCRIPTION="nl80211-based configuration utility for wireless devices using the mac80211 kernel stack"
  6. HOMEPAGE="https://wireless.kernel.org/en/users/Documentation/iw"
  7. SRC_URI="https://www.kernel.org/pub/software/network/${PN}/${P}.tar.xz"
  8. LICENSE="ISC"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
  11. IUSE=""
  12. RDEPEND="dev-libs/libnl"
  13. DEPEND="${RDEPEND}
  14. virtual/pkgconfig"
  15. src_prepare() {
  16. tc-export CC LD PKG_CONFIG
  17. }
  18. src_compile() {
  19. CFLAGS="${CFLAGS} ${CPPFLAGS}" \
  20. LDFLAGS="${CFLAGS} ${LDFLAGS}" \
  21. emake V=1
  22. }
  23. src_install() {
  24. emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
  25. }