iw-4.7.ebuild 762 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit toolchain-funcs
  5. DESCRIPTION="nl80211-based configuration utility for wireless devices using the mac80211 kernel stack"
  6. HOMEPAGE="https://wireless.kernel.org/en/users/Documentation/iw"
  7. SRC_URI="https://www.kernel.org/pub/software/network/${PN}/${P}.tar.xz"
  8. LICENSE="ISC"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
  11. IUSE=""
  12. RDEPEND="dev-libs/libnl"
  13. DEPEND="${RDEPEND}
  14. virtual/pkgconfig"
  15. src_prepare() {
  16. default
  17. tc-export CC LD PKG_CONFIG
  18. }
  19. src_compile() {
  20. CFLAGS="${CFLAGS} ${CPPFLAGS}" \
  21. LDFLAGS="${CFLAGS} ${LDFLAGS}" \
  22. emake V=1
  23. }
  24. src_install() {
  25. emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
  26. }