openbsc-9999.ebuild 664 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools git-2 eutils
  5. DESCRIPTION="OpenBSC, OsmoSGSN, OsmoBSC and other programs"
  6. HOMEPAGE="http://openbsc.osmocom.org/trac/wiki/OpenBSC"
  7. EGIT_REPO_URI="git://git.osmocom.org/${PN}.git"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS=""
  11. IUSE="+gprs"
  12. DEPEND="
  13. gprs? ( net-wireless/openggsn )
  14. net-libs/libosmocore
  15. net-libs/libosmo-abis
  16. net-libs/libosmo-netif
  17. dev-db/libdbi"
  18. RDEPEND="${DEPEND}
  19. dev-db/libdbi-drivers[sqlite]
  20. dev-db/sqlite:3"
  21. S="${WORKDIR}/${P}/${PN}"
  22. EGIT_SOURCEDIR="${WORKDIR}/${P}"
  23. src_prepare() {
  24. epatch_user
  25. eautoreconf
  26. }