osmobts-9999.ebuild 801 B

123456789101112131415161718192021222324252627282930
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools git-2
  5. DESCRIPTION="Osmocom BTS-Side code (Abis, scheduling)"
  6. HOMEPAGE="http://openbsc.osmocom.org/trac/wiki/OsmoBTS"
  7. EGIT_REPO_URI="git://git.osmocom.org/osmo-bts.git"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS=""
  11. IUSE=""
  12. DEPEND="net-libs/libosmocore net-libs/libosmo-abis"
  13. RDEPEND="${DEPEND}"
  14. src_prepare() {
  15. eautoreconf
  16. wget -O "${S}"/include/openbsc/gsm_data_shared.h http://cgit.osmocom.org/openbsc/plain/openbsc/include/openbsc/gsm_data_shared.h || die
  17. wget -O "${S}"/src/common/gsm_data_shared.c http://cgit.osmocom.org/openbsc/plain/openbsc/src/libcommon/gsm_data_shared.c || die
  18. }
  19. src_configure() {
  20. econf --enable-trx --with-openbsc="${S}"/include/openbsc
  21. }