pyrit-0.4.0-r1.ebuild 764 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. DISTUTILS_SINGLE_IMPL=1
  6. inherit distutils-r1
  7. DESCRIPTION="GPU-accelerated attack against WPA-PSK authentication"
  8. HOMEPAGE="https://github.com/JPaulMora/Pyrit"
  9. SRC_URI="https://github.com/JPaulMora/${PN^}/archive/${PV}.tar.gz -> ${P}.tar.gz"
  10. LICENSE="GPL-3+"
  11. SLOT="0"
  12. KEYWORDS="~amd64 ~x86"
  13. IUSE="cuda opencl test"
  14. DEPEND="dev-libs/openssl
  15. net-libs/libpcap
  16. test? ( >=net-analyzer/scapy-2[${PYTHON_USEDEP}] )"
  17. RDEPEND=">=net-analyzer/scapy-2
  18. opencl? ( net-wireless/cpyrit-opencl )
  19. cuda? ( net-wireless/cpyrit-cuda )"
  20. pkg_setup() {
  21. python-single-r1_pkg_setup
  22. }
  23. src_test() {
  24. cd test
  25. "${PYTHON}" test_pyrit.py
  26. }