gonvert-0.2.39.ebuild 783 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit python-single-r1
  6. DESCRIPTION="Unit conversion utility written in PyGTK"
  7. HOMEPAGE="http://unihedron.com/projects/gonvert/index.php"
  8. SRC_URI="http://unihedron.com/projects/gonvert/downloads/${P}.tar.gz"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
  12. IUSE=""
  13. REQUIRED_USE="${PYTHON_REQUIRED_USE}"
  14. RDEPEND="
  15. ${PYTHON_DEPS}
  16. dev-python/pygtk:2[${PYTHON_USEDEP}]"
  17. DEPEND="${RDEPEND}"
  18. PATCHES=( "${FILESDIR}"/0.2.23-paths.patch )
  19. src_install () {
  20. emake install DESTDIR="${D}" prefix="${EPREFIX}/usr"
  21. python_fix_shebang "${ED%/}"/usr/bin
  22. rm -fr "${ED%/}/usr/share/doc/${PN}" || die
  23. einstalldocs
  24. }