ParmEd-2.7.3.ebuild 855 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
  5. if [[ $PV = *9999* ]]; then
  6. scm_eclass=git-2
  7. EGIT_REPO_URI="
  8. git://github.com/${PN}/${PN}.git
  9. https://github.com/${PN}/${PN}.git"
  10. SRC_URI=""
  11. KEYWORDS=""
  12. else
  13. scm_eclass=vcs-snapshot
  14. SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
  15. KEYWORDS="~amd64 ~x86"
  16. fi
  17. inherit eutils distutils-r1 ${scm_eclass}
  18. DESCRIPTION="Parameter/topology editor and molecular simulator"
  19. HOMEPAGE="http://parmed.github.io/ParmEd"
  20. LICENSE="LGPL-2"
  21. SLOT="0"
  22. IUSE=""
  23. DEPEND="
  24. dev-python/numpy[${PYTHON_USEDEP}]
  25. sci-libs/scipy[${PYTHON_USEDEP}]
  26. "
  27. RDEPEND="${DEPEND}"
  28. src_prepare() {
  29. sed \
  30. -e "/delfile/d" \
  31. -e "/deldir/d" \
  32. -i setup.py || die
  33. distutils-r1_src_prepare
  34. }