autodock_vina-1.1.2.ebuild 932 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils flag-o-matic versionator
  5. MY_P="${PN}_$(replace_all_version_separators _)"
  6. DESCRIPTION="Program for drug discovery, molecular docking and virtual screening"
  7. HOMEPAGE="http://vina.scripps.edu/"
  8. SRC_URI="http://vina.scripps.edu/download/${MY_P}.tgz"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. LICENSE="Apache-2.0"
  12. IUSE="debug"
  13. RDEPEND="dev-libs/boost[threads]"
  14. DEPEND="${RDEPEND}"
  15. S="${WORKDIR}"/${MY_P}/build/linux/release
  16. src_prepare() {
  17. cd "${WORKDIR}"/${MY_P} || die
  18. epatch \
  19. "${FILESDIR}"/${PV}-gentoo.patch \
  20. "${FILESDIR}"/${P}-boost-filesystem.patch
  21. }
  22. src_compile() {
  23. local c_options
  24. use debug || c_options="-DNDEBUG"
  25. append-cxxflags -DBOOST_FILESYSTEM_VERSION=3
  26. emake \
  27. BASE="${EPREFIX}"/usr/ \
  28. GPP="$(tc-getCXX)" \
  29. C_OPTIONS="${c_options}"
  30. }
  31. src_install() {
  32. dobin vina{,_split}
  33. }