easychem-0.6-r1.ebuild 811 B

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils toolchain-funcs
  5. DESCRIPTION="Chemical structure drawing program - focused on presentation"
  6. HOMEPAGE="http://easychem.sourceforge.net/"
  7. SRC_URI="mirror://sourceforge/easychem/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ~ppc x86 ~amd64-linux ~x86-linux"
  11. IUSE=""
  12. RDEPEND="
  13. x11-libs/gtk+:2
  14. app-text/ghostscript-gpl
  15. media-gfx/pstoedit"
  16. DEPEND="${RDEPEND}
  17. dev-lang/perl
  18. virtual/pkgconfig"
  19. src_prepare() {
  20. epatch "${FILESDIR}"/${PV}-gentoo.patch
  21. tc-export CC
  22. }
  23. src_compile() {
  24. ln -s Makefile.linux Makefile || die
  25. DGS_PATH="${EPREFIX}"/usr/bin DPSTOEDIT_PATH="${EPREFIX}"/usr/bin \
  26. C_FLAGS="${CFLAGS}" emake -e
  27. }
  28. src_install () {
  29. dobin easychem
  30. dodoc TODO
  31. }