gamessq-1.2.ebuild 580 B

123456789101112131415161718192021222324252627
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. WX_GTK_VER="2.8"
  5. inherit eutils wxwidgets
  6. DESCRIPTION="Simple job manager for GAMESS-US"
  7. HOMEPAGE="http://www.msg.chem.iastate.edu/GAMESS/GamessQ/"
  8. SRC_URI="http://www.msg.chem.iastate.edu/GAMESS/GamessQ/download/${P}.tar.gz"
  9. LICENSE="GPL-3"
  10. KEYWORDS="~amd64 ~x86"
  11. SLOT="0"
  12. IUSE=""
  13. DEPEND="x11-libs/wxGTK:${WX_GTK_VER}"
  14. RDEPEND="${DEPEND}"
  15. src_install() {
  16. default
  17. doicon src/icons/${PN}.ico
  18. make_desktop_entry ${PN} gamessq ${PN}.ico "Science;Education"
  19. }