povscript+-2.1.2.2.20.ebuild 1.2 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils versionator
  5. V1=$(get_version_component_range 1 ${PV})
  6. V2=$(get_version_component_range 2 ${PV})
  7. V3=$(get_version_component_range 3 ${PV})
  8. V4=$(get_version_component_range 4 ${PV})
  9. V5=$(get_version_component_range 5 ${PV})
  10. MY_P=molscript-${V1}.${V2}.${V3}pov${V4}.${V5}
  11. DESCRIPTION="Modified molscript that uses POV-Ray, does thermal ellipsoids, and more"
  12. HOMEPAGE="https://sites.google.com/site/timfenn/povscript"
  13. SRC_URI="https://sites.google.com/site/timfenn/povscript/${MY_P}.tar.gz"
  14. SLOT="0"
  15. LICENSE="glut molscript"
  16. KEYWORDS="~amd64 ~ppc ~x86"
  17. IUSE=""
  18. RDEPEND="
  19. dev-libs/glib:2
  20. media-libs/freeglut
  21. media-libs/giflib
  22. >=media-libs/libpng-1.4:0=
  23. sci-libs/gts
  24. sys-libs/zlib
  25. virtual/glu
  26. virtual/jpeg:0
  27. virtual/opengl
  28. x11-libs/libX11"
  29. DEPEND="${RDEPEND}"
  30. S=${WORKDIR}/${MY_P}
  31. src_prepare() {
  32. epatch "${FILESDIR}"/${PN}-2.1.2.2.19-libpng15.patch
  33. }
  34. src_install() {
  35. default
  36. cd "${ED}"/usr/bin || die
  37. mv molscript povscript+ || die
  38. mv molauto povauto+ || die
  39. }
  40. pkg_postinst() {
  41. elog "You must install media-gfx/povray to use the POV backend,"
  42. elog "which is one of the main features of this over molscript."
  43. }