prodecomp-3.0-r1.ebuild 1.0 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. PYTHON_REQ_USE="tk"
  6. inherit python-single-r1
  7. DESCRIPTION="Decomposition-based analysis of NMR projections"
  8. HOMEPAGE="http://www.lundberg.gu.se/nmr/software.php?program=PRODECOMP"
  9. SRC_URI="mirror://gentoo/${P}.tar.bz2"
  10. SLOT="0"
  11. LICENSE="GPL-2"
  12. KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
  13. IUSE="examples"
  14. RDEPEND="sci-libs/scipy[${PYTHON_USEDEP}]"
  15. DEPEND=""
  16. S="${WORKDIR}"/NMRProjAnalys
  17. src_install() {
  18. python_export
  19. if use examples; then
  20. insinto /usr/share/${PN}
  21. doins -r ExampleData Results
  22. fi
  23. dodoc ProjTools/Manual.pdf
  24. rm -rf ProjTools/Manual.pdf ProdecompOutput || die
  25. python_moduleinto ${PN}
  26. python_domodule ProjTools/.
  27. python_optimize
  28. cat >> "${T}"/${PN} <<- EOF
  29. #!/bin/bash
  30. ${PYTHON} -O $(python_get_sitedir)/${PN}/ProjAnalys.py \$@
  31. EOF
  32. dobin "${T}"/${PN}
  33. dosym ../../../../share/doc/${PF}/Manual.pdf "${PYTHON_SITEDIR##${EPREFIX}}"/${PN}/Manual.pdf
  34. }