reduce-3.14.080821.ebuild 1.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051
  1. # Copyright 1999-2011 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit eutils toolchain-funcs
  5. MY_P="${PN}.${PV}.src"
  6. DESCRIPTION="Adds hydrogens to a Protein Data Bank (PDB) molecule structure file"
  7. HOMEPAGE="http://kinemage.biochem.duke.edu/software/reduce.php"
  8. SRC_URI="http://kinemage.biochem.duke.edu/downloads/software/reduce31/${MY_P}.tgz"
  9. LICENSE="richardson"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
  12. IUSE=""
  13. RDEPEND=""
  14. DEPEND="${RDEPEND}
  15. app-arch/unzip"
  16. S="${WORKDIR}/${MY_P}"
  17. src_prepare() {
  18. epatch \
  19. "${FILESDIR}"/3.13.080428-LDFLAGS.patch \
  20. "${FILESDIR}"/${PV}-CFLAGS.patch
  21. }
  22. src_compile() {
  23. DICT_DIR="/usr/share/reduce"
  24. DICT_FOLD="reduce_het_dict.txt"
  25. DICT_FNEW="reduce_wwPDB_het_dict.txt"
  26. emake clean
  27. emake \
  28. CC="$(tc-getCC)" \
  29. CXX="$(tc-getCXX)" \
  30. OPT="${CXXFLAGS}" \
  31. DICT_HOME="${EPREFIX}/${DICT_DIR}/${DICT_FNEW}" \
  32. DICT_OLD="${EPREFIX}/${DICT_DIR}/${DICT_FOLD}"
  33. }
  34. src_install() {
  35. dobin "${S}"/reduce_src/reduce
  36. insinto ${DICT_DIR}
  37. doins "${S}"/${DICT_FOLD} "${S}"/${DICT_FNEW}
  38. dodoc README.usingReduce.txt
  39. }