suitename-0.3.070628.ebuild 760 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit toolchain-funcs
  5. MY_P="${PN}.${PV}"
  6. DESCRIPTION="The ROC RNA Ontology Consortium consensus RNA backbone nomenclature and conformer-list development"
  7. HOMEPAGE="http://kinemage.biochem.duke.edu/software/suitename.php"
  8. SRC_URI="http://kinemage.biochem.duke.edu/downloads/software/${PN}/${MY_P}.src.tgz"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
  11. LICENSE="richardson"
  12. IUSE=""
  13. S="${WORKDIR}"/${MY_P}
  14. src_prepare() {
  15. tc-export CC
  16. cp Makefile.linux Makefile || die
  17. sed \
  18. -e 's:cc:${CC}:g' \
  19. -e "s:-o:${LDFLAGS} -o:g" \
  20. -i Makefile || die
  21. }
  22. src_compile() {
  23. emake CFLAGS="${CFLAGS}"
  24. }
  25. src_install() {
  26. dobin ${PN}
  27. }