votca-csgapps-9999.ebuild 673 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. CMAKE_MAKEFILE_GENERATOR="ninja"
  5. inherit cmake-utils
  6. if [ "${PV}" != "9999" ]; then
  7. SRC_URI="https://github.com/${PN/-//}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  8. KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-macos"
  9. S="${WORKDIR}/${P#votca-}"
  10. else
  11. inherit git-r3
  12. EGIT_REPO_URI="git://github.com/${PN/-//}.git https://github.com/${PN/-//}.git"
  13. KEYWORDS=""
  14. fi
  15. DESCRIPTION="Extra applications for votca-csg"
  16. HOMEPAGE="http://www.votca.org"
  17. LICENSE="Apache-2.0"
  18. SLOT="0"
  19. IUSE=""
  20. RDEPEND="~sci-chemistry/${PN%apps}-${PV}"
  21. DEPEND="${RDEPEND}"
  22. DOCS=( README )