wxmacmolplt-7.5-r1.ebuild 968 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. WX_GTK_VER=3.0
  5. inherit autotools eutils wxwidgets
  6. DESCRIPTION="Chemical 3D graphics program with GAMESS input builder"
  7. HOMEPAGE="http://www.scl.ameslab.gov/MacMolPlt/"
  8. SRC_URI="https://wxmacmolplt.googlecode.com/files/${P}.tar.gz"
  9. LICENSE="GPL-2"
  10. KEYWORDS="~amd64 ~x86"
  11. SLOT="0"
  12. IUSE="flash"
  13. RDEPEND="
  14. media-libs/glew:0=
  15. media-libs/mesa
  16. x11-libs/wxGTK:${WX_GTK_VER}[X,opengl]
  17. flash? ( media-libs/ming )"
  18. DEPEND="${RDEPEND}
  19. virtual/pkgconfig"
  20. src_prepare() {
  21. need-wxwidgets unicode
  22. epatch "${FILESDIR}"/${P}-glew.patch
  23. sed \
  24. -e "/^dist_doc_DATA/d" \
  25. -i Makefile.am || die "Failed to disable installation of LICENSE file"
  26. eautoreconf
  27. }
  28. src_configure() {
  29. econf \
  30. --with-glew \
  31. $(use_with flash ming)
  32. }
  33. src_install() {
  34. default
  35. doicon resources/${PN}.png
  36. make_desktop_entry ${PN} wxMacMolPlt ${PN} "Science;DataVisualization;"
  37. }