gerbv-2.6.1.ebuild 1.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="6"
  4. inherit autotools eutils fdo-mime
  5. DESCRIPTION="A RS-274X (Gerber) and NC drill (Excellon) file viewer"
  6. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
  7. HOMEPAGE="http://gerbv.geda-project.org/"
  8. IUSE="doc examples static-libs unit-mm"
  9. SLOT="0"
  10. LICENSE="GPL-2"
  11. KEYWORDS="~amd64 ~ppc ~x86"
  12. RESTRICT="test"
  13. RDEPEND="
  14. x11-libs/gtk+:2
  15. x11-libs/cairo"
  16. DEPEND="${RDEPEND}
  17. virtual/pkgconfig"
  18. src_prepare() {
  19. # No Russian translation shipped
  20. echo > po/LINGUAS || die
  21. eapply "${FILESDIR}"/${P}-ru.patch
  22. eapply_user
  23. eautoreconf
  24. }
  25. src_configure() {
  26. econf \
  27. $(use_enable static-libs static) \
  28. $(use_enable unit-mm) \
  29. --disable-update-desktop-database
  30. }
  31. src_install () {
  32. default
  33. dodoc AUTHORS BUGS ChangeLog CONTRIBUTORS HACKING NEWS README* TODO
  34. rm doc/Doxyfile.nopreprocessing
  35. if use doc; then
  36. find doc -name "Makefile*" -exec rm -f '{}' \;
  37. dodoc -r doc/*
  38. fi
  39. if use examples; then
  40. find example -name "Makefile*" -exec rm -f '{}' \;
  41. dodoc -r example/*
  42. fi
  43. prune_libtool_files
  44. }
  45. pkg_postinst() {
  46. fdo-mime_desktop_database_update
  47. }
  48. pkg_postrm() {
  49. fdo-mime_desktop_database_update
  50. }