io_lib-1.12.5.ebuild 809 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. DESCRIPTION="General purpose trace and experiment file reading/writing interface"
  5. HOMEPAGE="http://staden.sourceforge.net/"
  6. SRC_URI="mirror://sourceforge/staden/${P}.tar.gz"
  7. LICENSE="BSD"
  8. SLOT="0"
  9. KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
  10. IUSE="static-libs"
  11. # needs stadden, not in portage
  12. RESTRICT=test
  13. # Prototype changes in io_lib-1.9.0 create incompatibilities with BioPerl. (Only
  14. # versions 1.8.11 and 1.8.12 will work with the BioPerl Staden extensions.)
  15. #DEPEND="!sci-biology/bioperl"
  16. DEPEND="net-misc/curl
  17. sys-libs/zlib"
  18. RDEPEND="${DEPEND}"
  19. src_configure() {
  20. econf $(use_enable static-libs static)
  21. }
  22. src_install() {
  23. default
  24. dodoc docs/{Hash_File_Format,ZTR_format}
  25. }