io_lib-1.13.2.ebuild 795 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools-utils
  5. DESCRIPTION="General purpose trace and experiment file reading/writing interface"
  6. HOMEPAGE="http://staden.sourceforge.net/"
  7. SRC_URI="mirror://sourceforge/staden/${P}.tar.gz"
  8. LICENSE="BSD"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
  11. IUSE="static-libs"
  12. # needs stadden, not in portage
  13. RESTRICT=test
  14. # Prototype changes in io_lib-1.9.0 create incompatibilities with BioPerl. (Only
  15. # versions 1.8.11 and 1.8.12 will work with the BioPerl Staden extensions.)
  16. #DEPEND="!sci-biology/bioperl"
  17. DEPEND="
  18. net-misc/curl
  19. sys-libs/zlib"
  20. RDEPEND="${DEPEND}"
  21. src_install() {
  22. autotools-utils_src_install
  23. dodoc docs/{Hash_File_Format,ZTR_format}
  24. }