io_lib-1.14.7.ebuild 719 B

123456789101112131415161718192021222324252627282930313233343536
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit eutils
  5. DESCRIPTION="General purpose trace and experiment file reading/writing interface"
  6. HOMEPAGE="http://staden.sourceforge.net/"
  7. SRC_URI="mirror://sourceforge/staden/${P}.tar.gz"
  8. LICENSE="BSD"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
  11. IUSE="static-libs"
  12. DEPEND="
  13. net-misc/curl
  14. sys-libs/zlib"
  15. RDEPEND="${DEPEND}"
  16. # tests fails and might need sci-biology/staden from
  17. # the science overlay
  18. RESTRICT="test"
  19. src_configure() {
  20. econf $(use static-libs static)
  21. }
  22. src_install() {
  23. default
  24. use static-libs || prune_libtool_files
  25. dodoc docs/{Hash_File_Format,ZTR_format}
  26. }