libsigrokdecode-0.3.0.ebuild 1.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. PYTHON_COMPAT=( python3_4 )
  5. inherit eutils python-single-r1 autotools
  6. if [[ ${PV} == "9999" ]]; then
  7. EGIT_REPO_URI="git://sigrok.org/${PN}"
  8. inherit git-r3 autotools
  9. else
  10. SRC_URI="http://sigrok.org/download/source/${PN}/${P}.tar.gz"
  11. KEYWORDS="~amd64 ~x86"
  12. fi
  13. DESCRIPTION="provide (streaming) protocol decoding functionality"
  14. HOMEPAGE="http://sigrok.org/wiki/Libsigrokdecode"
  15. LICENSE="GPL-3"
  16. SLOT="0"
  17. IUSE="static-libs"
  18. REQUIRED_USE="${PYTHON_REQUIRED_USE}"
  19. RDEPEND=">=dev-libs/glib-2.24.0
  20. ${PYTHON_DEPS}"
  21. DEPEND="${RDEPEND}
  22. virtual/pkgconfig"
  23. src_prepare() {
  24. epatch "${FILESDIR}"/${PN}-0.3.0-configure-test.patch
  25. epatch "${FILESDIR}"/${PN}-0.3.0-no-check-linkage.patch
  26. eautoreconf
  27. # Only a test program (not installed, and not used by src_test)
  28. # is used by libsigrok, so disable it to avoid the compile.
  29. sed -i \
  30. -e '/build_runtc=/s:yes:no:' \
  31. configure || die
  32. }
  33. src_configure() {
  34. econf $(use_enable static-libs static)
  35. }
  36. src_test() {
  37. emake check
  38. }
  39. src_install() {
  40. default
  41. prune_libtool_files
  42. }