libsigrokdecode-0.4.1.ebuild 1.0 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="6"
  4. PYTHON_COMPAT=( python3_4 )
  5. inherit eutils python-single-r1
  6. if [[ ${PV} == "9999" ]]; then
  7. EGIT_REPO_URI="git://sigrok.org/${PN}"
  8. inherit git-r3 autotools
  9. else
  10. SRC_URI="http://sigrok.org/download/source/${PN}/${P}.tar.gz"
  11. KEYWORDS="~amd64 ~x86"
  12. fi
  13. DESCRIPTION="provide (streaming) protocol decoding functionality"
  14. HOMEPAGE="http://sigrok.org/wiki/Libsigrokdecode"
  15. LICENSE="GPL-3"
  16. SLOT="0"
  17. IUSE="static-libs"
  18. REQUIRED_USE="${PYTHON_REQUIRED_USE}"
  19. RDEPEND=">=dev-libs/glib-2.24.0
  20. ${PYTHON_DEPS}"
  21. DEPEND="${RDEPEND}
  22. virtual/pkgconfig"
  23. src_prepare() {
  24. [[ ${PV} == "9999" ]] && eautoreconf
  25. # Only a test program (not installed, and not used by src_test)
  26. # is used by libsigrok, so disable it to avoid the compile.
  27. sed -i \
  28. -e '/build_runtc=/s:yes:no:' \
  29. configure || die
  30. eapply_user
  31. }
  32. src_configure() {
  33. econf $(use_enable static-libs static)
  34. }
  35. src_test() {
  36. emake check
  37. }
  38. src_install() {
  39. default
  40. prune_libtool_files
  41. }