silo-4.9.1.ebuild 989 B

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils
  5. DESCRIPTION="A mesh and field I/O library and scientific database"
  6. HOMEPAGE="https://wci.llnl.gov/codes/${PN}"
  7. SRC_URI="https://wci.llnl.gov/codes/${PN}/${P}/${P}.tar.gz"
  8. SLOT="0"
  9. LICENSE="BSD"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="hdf5 +silex static-libs qt4 test"
  12. REQUIRED_USE="silex? ( qt4 )"
  13. RDEPEND="
  14. hdf5? ( sci-libs/hdf5 )
  15. qt4? ( dev-qt/qtgui:4 )"
  16. DEPEND="${RDEPEND}"
  17. src_prepare() {
  18. epatch "${FILESDIR}/${P}-qtlibs.patch"
  19. epatch "${FILESDIR}/${P}-tests.patch"
  20. }
  21. src_configure() {
  22. econf \
  23. --enable-install-lite-headers \
  24. --enable-shared \
  25. $(use_enable silex silex ) \
  26. $(use_enable static-libs static ) \
  27. $(use_with qt4 Qt-lib-dir "${EPREFIX}"/usr/lib${LIB_LOCATION_SUFFIX}/qt4 ) \
  28. $(use_with qt4 Qt-include-dir "${EPREFIX}"/usr/include/qt4 ) \
  29. $(use_with hdf5 hdf5 ${EPREFIX}"/usr/include,${EPREFIX}"/usr/lib${LIB_LOCATION_SUFFIX} )
  30. }