4ti2-1.6.2.ebuild 789 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. AUTOTOOLS_AUTORECONF=true
  5. # The swig subdir is not used, so we can skip running autotools in it. #518000
  6. AT_NO_RECURSIVE=1
  7. inherit autotools-utils
  8. DESCRIPTION="Software package for algebraic, geometric and combinatorial problems"
  9. HOMEPAGE="http://www.4ti2.de/"
  10. SRC_URI="http://4ti2.de/version_${PV}/${P}.tar.gz"
  11. LICENSE="GPL-2"
  12. SLOT="0"
  13. KEYWORDS="amd64 x86 ~x86-macos"
  14. IUSE="static-libs"
  15. DEPEND="
  16. sci-mathematics/glpk:0[gmp]
  17. dev-libs/gmp[cxx]"
  18. RDEPEND="${DEPEND}"
  19. AUTOTOOLS_IN_SOURCE_BUILD=1
  20. PATCHES=(
  21. "${FILESDIR}"/${PN}-1.3.2-gold.patch
  22. )
  23. src_prepare() {
  24. sed \
  25. -e "s:^CXX.*$:CXX=$(tc-getCXX):g" \
  26. -i m4/glpk-check.m4 || die
  27. autotools-utils_src_prepare
  28. }