drgeo-1.1.0-r1.ebuild 1.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit eutils
  5. DOC="${PN}-doc-1.5"
  6. DESCRIPTION="Interactive geometry package"
  7. HOMEPAGE="http://www.ofset.org/drgeo"
  8. SRC_URI="
  9. mirror://sourceforge/ofset/${P}.tar.gz
  10. mirror://sourceforge/ofset/${DOC}.tar.gz"
  11. SLOT="0"
  12. LICENSE="GPL-2"
  13. KEYWORDS="~amd64 ~ppc ~x86"
  14. IUSE="nls"
  15. RDEPEND="
  16. dev-libs/libxml2:2
  17. dev-scheme/guile:=[deprecated]
  18. gnome-base/libglade:2.0
  19. x11-libs/gtk+:2"
  20. DEPEND="${RDEPEND}
  21. virtual/pkgconfig"
  22. PATCHES=( "${FILESDIR}"/${P}-gcc45.patch )
  23. src_configure() {
  24. default
  25. # Can't make the documentation as it depends on Hyperlatex which isn't
  26. # yet in portage. Fortunately HTML is already compiled for us in the
  27. # tarball and so can be installed. Just create the make install target.
  28. cd "${WORKDIR}"/${DOC} || die
  29. econf
  30. }
  31. src_install() {
  32. sed -i -e "s/gnome-drgenius.png/${PN}/" \
  33. -e '/^Categories=/s/Application;//' \
  34. ${PN}.desktop || die
  35. default
  36. emake -C "${WORKDIR}"/${DOC}/$(usex nls "" c) DESTDIR="${D}" install
  37. doicon glade/${PN}.png
  38. }