dunshire-0.1.1.ebuild 696 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PYTHON_COMPAT=( python3_{4,5} )
  5. inherit distutils-r1
  6. DESCRIPTION="Python library to solve linear games over symmetric cones"
  7. HOMEPAGE="http://michael.orlitzky.com/code/dunshire"
  8. SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
  9. LICENSE="AGPL-3+"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. IUSE="doc test"
  13. RDEPEND="dev-python/cvxopt[${PYTHON_USEDEP}]"
  14. DEPEND="${RDEPEND}
  15. dev-python/setuptools[${PYTHON_USEDEP}]"
  16. python_install_all() {
  17. use doc && local HTML_DOCS=( doc/build/html/. )
  18. local DOCS=( doc/README.rst )
  19. distutils-r1_python_install_all
  20. }
  21. python_test() {
  22. esetup.py test
  23. }