flint-2.3.ebuild 704 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit eutils multilib
  5. DESCRIPTION="Fast Library for Number Theory"
  6. HOMEPAGE="http://www.flintlib.org/"
  7. SRC_URI="http://www.flintlib.org/${P}.tar.gz"
  8. RESTRICT="mirror"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. IUSE=""
  13. DEPEND="dev-libs/mpfr:0
  14. dev-libs/ntl
  15. sci-libs/mpir
  16. "
  17. RDEPEND="${DEPEND}"
  18. src_prepare() {
  19. # Correct lib paths to be multilib-proper #470732
  20. sed -i -e 's~/lib~/'$(get_libdir)'~' Makefile.in || die
  21. }
  22. src_configure() {
  23. # handwritten script, needs extra stabbing
  24. ./configure --with-mpir=/usr --with-mpfr=/usr --with-ntl=/usr --prefix="${D}/usr" || die
  25. }